QLOOKアクセス解析

とある濁酒の便利ツールこのブログは便利なフリーソフトについて私まっこりーにが 私的に語って行くブログです。 

この記事に含まれるタグ :
Chrome  Dev  不具合  

スポンサーサイト

   ↑  --/--/-- (--)  --:--  カテゴリー: スポンサー広告
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
はてなブックマーク  Google Bookmarks  Yahoo!ブックマーク  livedoorクリップ  Twitter   

(記事編集) http://makkori1105.blog133.fc2.com/?overture" target="_new

--/--/-- | Comment (-) | HOME | ↑ ページ先頭へ ↑ |

Chrome7.0.544.0 dev 検索不具合パートⅡ

   ↑  2010/10/12 (火)  05:25  カテゴリー: Dev版体験記
はーい、こんばんはー、本日は「前回の記事の後報」になります~。

前回の記事は、この記事の下にありますので、まだ見て無い方は御覧ください。

前回、結局原因がハッキリしないまま「Cookie」の削除で状況が改善した訳ですが、
前回記事に書いていた通り、やはりまた同じ状態となりました(。´-д-)

同じ状態が再現出来たので、前回撮れなかった「エラーページ」と「実験機能」が
この件に関わってるかどうかの検証もしてみました。

【エラー画面】

エラーページ(英語)   エラーページ(翻訳後)


※右の画像はGoogle翻訳後の画像です。


この画面は、検索エンジンのカスタマイズで日付パラメーターを付け加えたGoogle検索を
既定の検索エンジンとして「Dev版」で使用してると起こるエラーの様です。

画像の一番下に出てるURLが僕が指定してるパラメーターのURLなのですが、これは
ずいぶん前にどこかのサイトを参考にして作った物で、Dev版以下のChromeでは
不具合等は出ていませんでした。

【今回わかった事】

①このエラーが出た際は「Google、Chrome関連のCookieを削除」すると
 症状が一旦改善される。(約1日程度)

②Google検索を繰り返し行なっていると突如この状態になる。
 (デフォルトのGoogle検索エンジンでは起こりません、カスタマイズした場合のみです)

③実験機能を全て「無効」にしても症状は改善されなかった。


エラーの度に毎回Cookie削除なんてやってられませんよね?w

エラーページを見てもエラーの原因になってるのは、やはり僕がカスタマイズしてる
検索エンジンの様なので、しばらく考えてみました。

「デフォルトの検索エンジン(google.co.jp)」では、この問題は起こらない。
日付パラメーターは「&as_qdr=○○」これを検索URLの末尾に加えるだけ。
Dev版までは、何のエラーも出なかった・・・。

「デフォルト」・・・ん?
「デフォルトの検索URLを見てみる」

{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s

「これに日付パラメーターを付け加えただけでエラーが起きるのだろうか・・・。」

「今使ってるURLと見比べてみる」

http://www.google.co.jp/search?q=%s&rls=com.microsoft:{language}:{referrer:source?}&ie={inputEncoding}&oe={outputEncoding}&sourceid=ie7&rlz=1I7GGLL_ja&as_qdr=y15

(; ・`д・´) ハッ!?

『Microsoftだと??』

デフォルトとちょっと違うじゃまいか・・・。
しかもよく見ると、検索エンジンの編集画面の「キーワード欄に!マーク」が点灯している。

検索編集画面

「デフォルトの検索エンジンのキーワードはgoogle.co.jp」になっていたので変更してみるも
状態変わらず「!マーク」が点灯したままに。

「デフォルトの検索URL」の末尾に日付パラメーターを加えたバージョンを作ってみる。

「キーワード」は「同じくgoogle」に設定してみる。

【!マークの点灯が消えチェックマークが入った】


早速「新たに作った日付検索」で検索してみる。

なぜか「本家の検索(英語)になる」

検索設定で日本語に1度直すと、次からは日本語検索になった。


まぁ、これが原因だったかどうか全く分からないんですがね・・・・w

これから1~2日使ってみてエラーが出なければ、恐らくコレが原因じゃないかと思います。
再度エラーが出るなら、Dev版と日付パラメーターの間の不具合か、
Dev版固有の不具合かと思うんですけど・・・ChromeでGoogle検索でエラーとか
ちょっと考え難いですよねw

これは、僕固有の問題だと思うんですが、現在のDev版で起っている不具合として、
「拡張機能画面でのクラッシュ」「オプション設定画面でのクラッシュ」が頻発しています。

「YouTube」の再生も不安定で、HTML5バージョンにしてもノーマルにしても
再生が始まらなかったり、クラッシュしたりする事が多々あります。

Chromeをメインブラウザーにしてから、初めて不安定なChromeを経験してる訳ですが、
それは、それで、結構楽しんでる自分が居たりします・・・w

って事で本日はこの辺でノシ

関連記事
スポンサーサイト

この記事に含まれるタグ : Chrome Dev 不具合 

FC2スレッドテーマ : ソフトウェア (ジャンル : コンピュータ

はてなブックマーク  Google Bookmarks  Yahoo!ブックマーク  livedoorクリップ  Twitter   

(記事編集) http://makkori1105.blog133.fc2.com/blog-entry-73.html

2010/10/12 | Comment (0) | Trackback (1) | HOME | ↑ ページ先頭へ ↑ |

Comment

コメントを投稿する 記事: Chrome7.0.544.0 dev 検索不具合パートⅡ

お気軽にコメントをぞうぞ。
非公開 (管理人のみ閲覧可能なコメント) にしたい場合には、ロック にチェックを入れてください。

  任意 : 後から修正や削除ができます。
  非公開コメントとして投稿する。(管理人にのみ公開)
 

Trackback


この記事にトラックバックする (FC2ブログユーザー限定)

-

管理人の承認後に表示されます

 2016/12/08
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。